• Welcome to KonaKart Community Forum. Please login or sign up.
 
March 23, 2019, 10:11:13 am

News:

KonaKart v8.9 - Released Aug-2018 - see KonaKart website for details


Problem with HTTPS

Started by sivaprakashcg, October 09, 2007, 11:10:40 am

Previous topic - Next topic

sivaprakashcg

Hi,
    I created developer account for autorize.net. When i was trying to confirm the order . It shows ssl error

Exception Name = javax.net.ssl.SSLKeyException
Exception Message = RSA premaster secret error
Exception Stack Trace =
at com.sun.net.ssl.internal.ssl.PreMasterSecret.(PreMasterSecret.java:86)
at com.sun.net.ssl.internal.ssl.ClientHandshaker.serverHelloDone(ClientHandshaker.java:515)
at com.sun.net.ssl.internal.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:160)
at com.sun.net.ssl.internal.ssl.Handshaker.processLoop(Handshaker.java:495)
at com.sun.net.ssl.internal.ssl.Handshaker.process_record(Handshaker.java:433)


So i thought problem with ssl.So i have enabled the ssl in admin.

So that am receiving this error

  "Error establishing an encrypted connection to localhost. Error Code:-12188"

So anybody help me.

Thanx in advance

paolo

Hi,

Is SSL actually working ? Can you check that when you attempt to log into the application, the url switches to https:// and everything works as before ?

-Paolo

sivaprakashcg

No its not changing..

Even if i enable the ssl in admin's app and then i am trying login(click on MyAccount).
It shows alert message as "Error establishing an encrypted connection to localhost. Error Code:-12188"

May i know.. How to configure the ssl

Can  u help me

paolo

Our wizard installation includes a non-trusted certificate so it should all work out of the box on Tomcat. Are you using some other servlet engine ? Did you do a manual installation ?

-Paolo

sivaprakashcg

Could u tell where is the manual for installation...??? Just i unzip the folder and changed some Properties files.

Is there need to change any thing for ssl.. Can u give some guidens..

paolo

What I suggest is for you to use the wizard installer which will set everything up correctly for you.

sivaprakashcg

Ok.. then where i have do fix the error..

paolo

After using the wizard installer there is no error ! Before going into production you may want to replace the certificate with a trusted one.

sivaprakashcg

Thank paolo
           But now am justing testing in my local system itself. At that time its not changing into http to https after login.