• Welcome to KonaKart Community Forum. Please login or sign up.

Error while updating registration data using MAC

Started by kajera, July 25, 2018, 05:21:56 pm

Previous topic - Next topic


My client uses the MAC computer to make changes to the job registry. When it tries to save changes Konakart displays the following message (attached).


What is the significance of you reporting that your client was using a Mac for this?  Does it work if you use a browser on a Windows machine?

More importantly, did you check the solr log that the error message refers to?  You should find useful information there.   You could also check the tomcat log for any problems at or before the time of the failure.


My client tested in Chrome on Windows and it worked normally, in IE Internet Explorer and Firefox also works.
But in Chorme and Safari on the MAC does not work.

I found an error in the solr log, but its not interpreting it ...



I'm not sure if there's much we can do to resolve that as it seems to be a problem with the browsers on the Mac.

A few things you could do to try/investigate:

Have you tried modifying the encoding settings on the browser? 

You could use a Developer mode on the browser to see what is being sent

You could enable the logging in Solr to see what the differences are between when it works and when it doesn't work?

Is it every single Mac that has this problem?  Have you tried others that may have different configurations?

Can you get any clues from Mac/Safari forms?


Problem solved \o/

The customer came back saying that the problem was only occurring in 2 products. Both on MAC and Windows.

I was able to replicate the problem at my local base.
Analyzing the log fo Solr I found a line saying that it has an invalid character in the register:

Caused by: com.ctc.wstx.exc.WstxUnexpectedCharException: Illegal character ((CTRL-CHAR, code 8))

I analyzed the register, identified the character, deleted it and everything went back to normal.

Obliged for help!