• Welcome to KonaKart Community Forum. Please login or sign up.

Downloaded KonaKart-, uploaded to server but then error

Started by java10, September 25, 2015, 11:48:56 am

Previous topic - Next topic



I'm trying to install KonaKart Community version on my VPS. I've downloaded Linux 64 version. I noticed that it isn't a ZIP file but rather my Win 10 machine recognizes it as a "0-LINUX-INSTALL-64-file" ? Is this OK? I uploaded the file as such (about 140 mb) to a directory on the server.

Now, I tried running this long command first:

./KonaKart- -S \ -DDatabaseType mysql \ -DDatabaseUrl jdbc:mysql://localhost:3306[other-db-stuff-here] \ -DInstallationDir ~/useraccount/shop [note: this is the subdomain i'd like to use - is this correct usage?] \ -DLoadDb 1

So this long command didn't work. I got this error/info:
-bash !Gl: event not found

Then I tried just:
./KonaKart- -S

and got this:

failed to load library "/installkitvfs/lib/itcl/libitcl3.4.so": could not load file from temp location: couldn't load file "/tmp/tcleNHHxy": /tmp/tcleNHHxy: failed to map segment from shared object: Operation not permitted

Please advise on how to proceed!



Do the "\" in the examples provided mean line breaks or do they really need to separate different options?


Quote from: java10 on September 25, 2015, 02:51:15 pm

Do the "\" in the examples provided mean line breaks or do they really need to separate different options?

Yet another edit:

My host did some changes on server restrictions. Now I'm able to run this command:

./KonaKart- -S -DDatabaseType mysql -DDatabaseUrl jdbc:mysql:://localhost:3306/useracc_shop1?zeroDateTimeBehavior=convertToNull -DDatabaseUsername useracc_shop1 -DInstallationDir ~/useracc/shop

(note: if I add password as well to the above, it shows error and last 3 chars of the pass: -bash !g! [<-- these are the last chars!]: event not found
I suspect that may be due to the pass having "!" in it or similar???)

After hitting Enter, nothing happens at all for some 3-4 sec, then on the next line prompt shows, nothing else. Is anything happening at all "behind the scenes" or I need to change my command? Too bad there's no info on what's happening or what's wrong.


Still no official reply but anyway, my hosting support helped me with this so it's installed but I can't access it due to probably not using the shipped tomcat but rather the one installed on the server.

Now I or they need to figure out what are the correct settings to use for the <host> part of the server.xml so that the subdomain loads sub.example.com/konakart when accessed.

In any case, I will be wanting to ditch the "/konakart" part anyway, so if anyone here knows how to do that - it'd be highly appreciated.