• Welcome to KonaKart Community Forum. Please login or sign up.

DB Oracle and Cannot access NLS data files or invalid environment specified

Started by sashav85, January 04, 2011, 01:33:12 pm

Previous topic - Next topic


Hi, all.

I am trying to install 5.0 version and have some trouble. When the server starts it returns the next message:
DB Error Msg:   java.sql.SQLException: ORA-00604: error occurred at recursive SQL level 1 ORA-12705: Cannot access NLS data files or invalid environment specified.

I've already encountered a similar problem when I used PLSQL Developer. But I solved it when I set NLS_LANG envirionment variable. In the registry I don't have any NLS keys.

I tried to change NLS_LANG env and set the registry key but it didn't give any result.

I use DB Oracle 10g Express Universal.



Rest assured that we run KonaKart on Oracle 10g Express all the time.

Oracle 10g Express is part of a large set of databases that we test every night.

Your problem appears to be an environmental problem with the Oracle set-up.

Perhaps this might help:



If anyone is interested, I solved my problem changing the system locale to US.


Hi, all.
Recently, I had a similar problem. And I did not want to change a locale so I decided to look for a solution to my problem. And it was very simple.

I copied(replaced) old jdbc driver from oracle 9g (I use 10g) to {konakart install dir}\webapps\konakart\WEB-INF\lib\
and {konakart install dir}\konakartadmin\WEB-INF\lib\ dirs.

And it worked.

I hope this information will be useful to someone.

P.S. I also set NLS_LANG env


Unfortunately, it seems that my solution is only suitable for installable version (not for *.zip).

Caused by: com.konakart.app.KKException: Unable to connect to the Database called null. Ensure that the database is running and if so, check the database connection parameters in the konakart.properties file under WEB-INF/classes.

I don't understand why "Database called null". In properties i have the "jdbc:oracle:thin:@localhost:1521:xe" line.


I have found a solution to the problem. In the konakart.properties files you need to change the line (for konakart and konakartadmin):

torque.dsfactory.store1.pool.validationQuery=SELECT 1

to line:

torque.dsfactory.store1.pool.validationQuery=SELECT 1 from dual

Installler does this automatically.